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Overview 

System Requirement 

Requirement Minimum Requirement Recommended Requirements 

OS Windows 10 64-bit Windows 10 64-bit 

Network - - 

Display 1920x1080 Resolution 1920x1080 Resolution or 

higher 

Processor Intel Core i5 Intel Core i7 9700K  

Video Card nVidia Dedicated GPU nVidia Dedicated GPU 

System RAM 16 GB 32 GB or higher 

Video RAM 1GB 4 GB or higher 

 

Requirement for the Operators 

This system is intended to be used by medical doctors or radiologists who 

has trained to use the system. Please use this software only for the 

intended purpose. 

 

Indication for use 

Module: Dicom Browser 

Browse and filter database 

Import and export of 4D Flow MR Images in Dicom Format. 

 

Module: iTFlow 

Color-coded flow display with semi-automatic contour detection, 

synchronization and forwarding 

 Graphical Display of flow rate and flow velocity. 

 Background correction options  

 Automatic calculations include volumes, velocities, regurgitant fraction  
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Abbreviations and Conventions  

References to buttons or icons and modules are written in italic.  

  

If the selection of a menu or function, requires multiple clicks, it will be 

notated as follows: E.g. Configuration > Contours > Rounded SAX Endocardial 

Contours (which explains how to get to the selection of using rounded contours 

for the automatic contour detection)  

  

Tooltips, names of menus and icons are written the same as in the interface, 

e.g. the button for the Short axis 3D volume module is described as Short3D  

  

  

CMR Cardiovascular imaging  

PC Phase Contrast  

 ROI Region of Interest 

LV left ventricle 

LA left atrium 

RV right ventricle 

RA right atrium 
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Getting started 

Principle of flow analysis using MRI 

Phase contrast image data and magnitude image data can be obtained by the phase 

contrast method. The phase contrast image is represent blood flow velocity in the 

gradient magnetic field direction. It is possible to analyze the blood flow velocity as 

a vector with components in three directions by acquiring phase images in three 

axes.  

 

 

Process 

Mask Segmentation 

Segmentation of the target vessels or ventricle is necessary for analysis. Mask 

image is overlayed on the phase image to define the region for analysis. 

 

Velocity vector visualization 

It is possible to visualize the blood flow velocity as a vector by composing the 

three-axis phase image. 

Hemodynamic parameter calculation 
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Blood flow rate, flow energy loss, wall shear stress, oscillatory shear index can 

be calculated from blood flow vector field. 
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Data Acquisition 

Data used in flow analysis 

PC images, magnitude image, cine images are used for analysis. 

 

PC Image（x, y z direction） 

   

These images contain velocity information of blood flow. It is essential for flow 

analysis. 

 

Magnitude Image 

 

Magnitude image is required with pc image. It is used for registration with PC 

image and CINE image. 

 

CINE Image 

High-contrast image such as True FISP, SSFP. It is used for segmentation. 
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Data requirement 

Series   

PC(3 axis) Required These data series must be included for flow 

analysis  

Magnitude Preferred This series can be used for registration. 

 

Cine preferred Using cine image enables tracking of heart beat. 

 

 

Vessels that receive less effect of movement with heartbeat such as 

abdominal aorta can be segmented from PC image. → See *** 

 

Launching the software 

Launch from DICOM Browser 

Click on Cardio Flow Station shortcut on the desktop to launch DICOM 

Browser. Multiple series for analysis can be selected by clicking with Ctrl key, then 

click “Flow Aanlysis” from right click menu to start 4D Flow analysis. 
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X, Y, Z PC image, images are necessary for analysis. Cine images. In 

addition to these series, importing Cine image makes the segmentation 

easier. 

 

 

 

Launch iTFlow stand alone. 

Click on iTFlow shortcut on the desktop and click File-> Import DICOM from menu 

to import dicom.  
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Dicom series can be easily imported by drag & drop the dicom folder on the desktop 

icon. 
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Importing Series Selection  

The imported series are automatically discriminated. If the selection of the PC-

X, Y,Z was wrong, it can be selected manually.  
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Data save and load 

Click on File->Save as in the menu to save the project file and the progress. Project 

files are contained from 5 files below. To move the project files, move the five files 

to same directory. 

メニューの File→Save asをクリックするとプロジェクトとして作業中のデータを保

存できます。プロジェクトは下記の 5つのファイルから構成されています。データを

移動させる場合は５つまとめて移動させてください。 

 

*.prj4d ：File used to import to the software. Relative file path of other four files 

are written.下記のファイルをまとめているファイル 

*_Cine.matg：Cine image data  Cine画像が保存されているファイル 

*_Magnitude.matg: Magnitude image Magnitude画像が保存されているファイル 

*_Mask.matm： Mask image data. This file can be imported or exported alone.マス

ク情報が保存されているファイル 

*_Velocity.matv：phase contrast image data. 位相画像が保存されているファイル 

 

 

Project file can be loaded from File -> Open in the menu. 
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2D Segmentation window 

 

① Segmentation control field 

Mask are semi-automatically generated using these functions.  

② Displaying switch 

③ Slice and Phase control 

Click to change the slice or phase. Checking radio button, slice or phase can 

bechanged using mouse wheel. Cine play is available from Play/Stop button 

④ Mouse functions 

Mask Draw/Erase 

Mask Erase 

Distance Measurement 

Angle Measurement 

Velocity Measurement 

 

⑤ Displaying Series 

⑥ 3D Display switch 

⑦ Opening 3D Viewer 

 

Mouse buttons function 

Right button Level change 

Middle button pan 

wheel Slice / Phase change 
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Ctrl＋wheel Zoom in out 
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ROI 

You can set region of interest to save system memory and processing time.  

 

 

This function is not necessary when the software processing speed does not have 

problem. 

 

Interpolation of Cine and Mask spatial resolution 

Clicking Edit -> Interpolation in the menu, spatial resolution of Cine image and 

Mask image can be changed. This function is useful to achieve smoother surface of 

the vessel and enables accurate calculation of WSS.  

 

Interpolation should be performed after setting ROI because it consumes large 

memory. 
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It is strongly recommended to set ROI before using interpolation, 

because interpolation uses high amount of memory. 

 

 

Segmentation  

Thresholding 
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Threshol 

 Use bar to change the threshold value.  The threshold value is important 

because it affect the time to segment in the following step and the accuracy of the 

analysis. 

 

Poor: near-wall region is not segmented enough. 

 

 

 

 

 

Good 

 

 

 

 

 

Poor: LV and PA are connected. It takes a lot 

of time to separate in the following process. 
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Separate  

Click Separate button and the Separate window popups. Push Separate 

button several times in the separate window to separate the region  

Select all the region by clicking from 2D View and push Apply button to 

delete unselected region. 

 

 

 

Manual segmenetation 

Mask can be modified manually using brush and eraser.  
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Draw/Erase. Left click to draw mask. Shift + left click to Erase the 

mask. 

Brush Size: brush size can be changed using mouse wheel when the 

cursol is on the text box.  

Brush size can be changed by Shift + Mouse wheel on 2D View. 

 

  



21 

 

3D Mask modification 

Click Erase button on 3D View. Clicking 3D View to make polygone and push 

delete key to erase. 

 

 

3D Viewer Moue controll  

Mouse right butotn rotate 

Mouse midd;le button Pan 

Mouse wheel Zoom 
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Auto(this phase) または Auto(all phase)で自動二値化 

 

Tracking：Based on displaying phase, the mask of all phases are 

automatically generated using tracking algorithm.  

Same mask to all: The mask of the displaying phase is copied to all other 

phases. This function is suitable for the vessel whose movement with heart 

beat is small. 

Mask save 

 

Save mask As:  mask can be saved to *.matm file 

Open Mask:  
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This function is useful when saving mask separately such as LV mask 

Aorta mask and RV mask.  

 

Flow visualization in 2D View 

 

Vector  

Velocity vector can be switched. The density of the vectors, size of the 

vectors and the color range can be changed from the setting. 

 

Energy loss 

Energy loss display can be switched. Color scale can be changed from the 

setting. 

Clicking Measure – Energy Loss to export the energy loss in the cardiac cycle. 
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Plane Reconstruction 

2D View plane can be reconstructed from 3D view  

  



25 

 

Velocity orientation correction 

This procedure have to be performed after finishing the mask segmentation in all 

phase. 

Click Edit -Orientation Velocity to Open orientation correction window. 

 

Please use this function after finishing making mask of all phases.  

 

 

 

Push Auto Orientation button and the orientation automatically corrected. If the 

vector direction is opposite, Push Reverse UVW button. 

 

Orientation can be manually set. Push “<” button and “>” button to change the 

orientation pattern.  

 

 

Auto orientation function is specification of PC image three axis combination 

based on streamline length. It is designed for vessel, and sometimes does not 

work corrector when segmenting heart. Please check whether the vector 

direction is correct after using auto orientation function. 

 

3D visualization / quantification 

3D Viewer will open by clicking Analysis in 3D Viewer button. 
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In this window, streamline, WSS, OSI, EL and vorticity are visualized in 3D.  

Flow rate and WSS can be quantified. 

   

 

 

   

  

View control 

Mouse Right button Tilt 

Mouse Middle Button Pan 

Mouse Wheel Zoom in/ out 
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Adjust View Button Reset Pan and Zoom 

 

Streamline 

Streamline display can be switched by checkbox. The number of lines, color 

range and line width can be modified from the setting button. 

WSS 

Color scale can be changed from the seting button. WSS quantification 

window will be opened by clicking measure WSS button. Click on the view to 

select the region. 

Shift + click to limit the region. 
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Flow rate 

After clicking Flow Rate button, flow rate can be calculated by mouse left 

button dragging to make cross section in 3D View. 

 

 

 

 

Mask edit in cross section view 

Left mouse button Draw 

Shift + Mouse Left button Erase 

Shift + Mouse Wheel Change brush size 
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Pathline 

Pathlines are the trajectories that individual fluid particles follow. These can be 

thought of as "recording" the path of a fluid element in the flow over a certain 

period. The direction the path takes will be determined by the streamlines of the 

fluid at each moment in time. 

 

Particle emission 

 Push Pathline Plane button 

 Drag mouse left button on the screen to make cross section. 

 Push OK button on the pathline window. 

 


